Pi-hole 2.8 Released With CentOS and RHEL Support, Plus More

Once again, thanks to those of you who are donating to Pi-hole.  We are happy to release Pi-hole core 2.8 with support for some new operating systems, better debugging, and some bug fixes.

How To Update

Just run the installer again…yeah it’s still weird.

More Platforms

Pi-hole can now install on CentOS and Red Hat!  macOS is in the works, too, but won’t be ready for some time.

rhelcentos

Better Debug Log Submission

We usually ask people for the output of pihole -d when troubleshooting a problem.  We have been using Pastebin as a place to post the log, but with 2.8, the debug command will upload your log file automatically to sprung.us termbin.com.  This just makes things a little easier.  If the site happens to be offline, your debug log will work just like it used to.

Bug Fixes

Recently one of the lists changed URLs and Pi-hole couldn’t find it.  We now follow redirects to find the appropriate URL so if the list moves, Pi-hole should follow the redirects to find it.  This should also prevent Pi-hole from losing a significant amount of blocked domains when updating its sources.

More…

Check out the change log for full details

 

7 Replies to “Pi-hole 2.8 Released With CentOS and RHEL Support, Plus More”

  1. How can i update the Pi Hole from 2.7 to 2.8.1 because if i run sudo pihole -u it tells me that i am already up to date but i am not. Do i need to uninstall it before i run the curl command again? if so then how do i uninstall it. I am using raspbian and a raspberry pi zero

    1. Hi there!

      Sorry it’s probably not very clear… the update command is for the web interface only. We are still working (slowly) on an update script for the entire thing… you can uninstall with `pihole uninstall` BUT.. just run the curl command again, and install over the top of the existing install and it will be fine!

      `curl -L https://install.pi-hole.net | bash`

      1. thank you very much for the answer i was quiet unsure about the update process itself.
        i did what you’ve said and now it tells me that i am using 2.8.1.
        Hope you guys get a nice new logo soon. But please dont choose an ugly one :s.

        1. We’re working on it! We were really impressed with all the submissions, and it’s been difficult to decide on just one! We may end up taking ideas from different ones and going with something else completely… but the competition still stands. Once we’ve worked out a fair voting system, the winner of that will probably get the prize!

      2. btw (slowly) i don’t care just take the time you guys need to make sure everything works great.
        dead lines are stupid xD good software needs time

        pi hole is great/awesome :p

Leave a Reply